WSUS Reset Server Node Error

So after installing WSUS on Server 2012, I returned to it the next day to see this:

Clicking Reset Server Node does nothing.


If you've ever dealt with WSUS for an extended period of time, you're probably used to this and if you haven't, get used to it.

So in the event viewer I saw these errors:

Always a fun way to start your Friday...


__

Event 7032

The WSUS administration console was unable to connect to the WSUS Server via the remote API. 

Verify that the Update Services service, IIS and SQL are running on the server. If the problem persists, try restarting IIS, SQL, and the Update Services Service.

The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists, 

Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.

System.IO.IOException -- The handshake failed due to an unexpected packet format.
__

Event 7053

The WSUS administration console has encountered an unexpected error. This may be a transient error; try restarting the administration console. If this error persists, 

Try removing the persisted preferences for the console by deleting the wsus file under %appdata%\Microsoft\MMC\.
__

Event 12072

The WSUS content directory is not accessible.
__

Event 12052

The DSS Authentication Web Service is not working.
__

Event 12042

The SimpleAuth Web Service is not working.
__

Event 12022

The Client Web Service is not working.
__

Event 12032

The Server Synchronization Web Service is not working.
__

Event 12012

The API Remoting Web Service is not working.
__

Event 12002

The Reporting Web Service is not working.
__

Event 13042

Self-update is not working.
__

That's a lot of errors and this is right after a WSUS reinstall. When I restarted, it seemed like it would work for a bit and then crash again.

After going into IIS Manager, I noticed that WSUS Pool has stopped under Application Pools. I dug around a bit and found that this is a memory issue for this particular application pool. 


In order to fix this, you have to select WsusPool and click Recycling.


Deselect Private memory usage (in KB)


Leave everything else the same and click Next. Then click Finish.


Now start WsusPool.




Now WSUS should start up for you.


Comments

Popular Tutorials